Issues with processing new ranks

Incident Report for SEOmonitor

Resolved

The incident has been resolved. No data was lost.
Posted Dec 14, 2025 - 13:54 EET

Monitoring

We identified an issue with processing new ranks, causing incorrect data to be displayed in the platform.
A fix was implemented, and while its results propagate, you might still notice inconsistencies.
Posted Dec 13, 2025 - 09:00 EET
This incident affected: Daily Keyword Tracker.