Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 19, 2026 - 09:00 EET
Scheduled
One of our third-party providers is performing a scheduled infrastructure upgrade to improve long-term performance and stability. We do not expect significant downtime, but delays in daily ranking data or slower processing of new keywords may occur during this window. Our engineering team will be monitoring the event closely to ensure any impact is kept to a minimum.
Posted Jan 18, 2026 - 15:32 EET
This scheduled maintenance affected: Daily Keyword Tracker and AI Content Writer.