Delays in processing daily ranks

Incident Report for SEOmonitor

Resolved

The incident has been resolved. No data was lost.
Posted Oct 22, 2025 - 18:34 EEST

Identified

We identified an issue causing delays in processing new ranks for today.
Posted Oct 22, 2025 - 10:36 EEST
This incident affected: Daily Keyword Tracker.