Competition data unavailable following infrastructure updates

Incident Report for SEOmonitor

Resolved

Access to the Competition data has been restored, and no data was lost.
Posted May 29, 2025 - 14:30 EEST

Identified

We have performed maintenance work on our servers, and access to Competition data throughout the platform is temporarily unavailable. We are working on implementing a prompt fix.
Posted May 29, 2025 - 12:44 EEST
This incident affected: Core Platform.