Delays in processing new campaigns and keywords

Incident Report for SEOmonitor

Resolved

The incident has been confirmed resolved on the provider side, and all our systems are back to normal. No data has been lost.
Posted Feb 07, 2025 - 11:30 EET

Identified

We are experiencing delays in processing new data (campaigns, keywords, keyword research) because of an ongoing incident at our third party Ads data provider.
Posted Feb 06, 2025 - 13:56 EET
This incident affected: Daily Keyword Tracker, Research Tools, and Keyword Import Processor.