Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 05, 2024 - 08:30 EET
Scheduled
We will be undergoing scheduled maintenance on the Romanian, French and "Global" servers for the Research Tools – Keyword Explorer, Domain Explorer, Keyword Vault.
This will not be impacting the UK and the US databases.
Posted Nov 04, 2024 - 12:10 EET
This scheduled maintenance affected: Research Tools.