Delays in processing new campaigns and keywords
Incident Report for SEOmonitor
Resolved
We have identified the issue as coming from an algorithm update. We have reversed it temporarily while we work on optimizing it further.
All systems are back to normal, and no data has been lost.
Posted Jul 04, 2024 - 16:15 EEST
Investigating
We are investigating an issue causing delays in processing data for new campaigns and/or new keywords.
Posted Jul 04, 2024 - 15:20 EEST
This incident affected: Daily Keyword Tracker and Keyword Import Processor.