Slow loading times (or downtime) across the platform
Incident Report for SEOmonitor
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 02:11 EET
Identified
We have identified an issue causing slow loading times (or downtime) across the platform, coming from an overload on the database entry point.
Posted Mar 05, 2024 - 02:06 EET