Dellays in article generation

Incident Report for SEOmonitor

Resolved

This incident has been resolved.
Posted Jun 11, 2026 - 11:56 EEST

Identified

We're currently experiencing an issue that delays article generation in the Content Writer section.
We identified the root cause and are working on the fix.
Posted Jun 11, 2026 - 11:09 EEST
This incident affected: AI Content Writer.