Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 16, 2024 - 10:00 EET
Scheduled
We will be undergoing scheduled maintenance on multiple markets Research database (RO and FR included). All Research tools on these markets will be experiencing downtime – Keyword Explorer, Domain Explorer, Keyword Vault.
UK and US markets will NOT be affected.
Posted Nov 13, 2024 - 12:56 EET
This scheduled maintenance affected: Research Tools.