Incident at one of our 3rd party providers

Incident Report for SEOmonitor

Resolved

This incident has been resolved. No data was lost.
Posted Jan 08, 2026 - 15:29 EET

Monitoring

Our third-party provider, Cloudflare, is investigating intermittent network performance issues.
We're monitoring the situation to identify whether their incident can impact our platform.
Posted Dec 19, 2025 - 13:38 EET
This incident affected: Core Platform.