Issues with detecting AI Overview data

Incident Report for SEOmonitor

Resolved

This incident has been resolved without any data loss.
Posted Feb 27, 2026 - 10:22 EET

Identified

We identified SERP changes causing issues with reading the AI Overview data.
We're currently working on the fix.
Posted Feb 19, 2026 - 14:49 EET
This incident affected: Daily Keyword Tracker.