Delays with new data in the Research tools
Incident Report for SEOmonitor
Resolved
The incident has been resolved and all Research products are back to the normal operating speed. No data has been lost.
Posted Dec 27, 2024 - 16:57 EET
Investigating
We are investigating an issue causing delays in processing new keywords in the Research tools: Keyword Explorer, Domain Explorer, and Keyword Lists (Vault).
Posted Dec 27, 2024 - 16:25 EET
This incident affected: Research Tools.