Delays in processing traffic data
Incident Report for SEOmonitor
Resolved
The incident has been resolved, and all processing is back to normal. No data has been lost.
Posted Oct 26, 2024 - 11:07 EEST
Investigating
We are investigating an issue with one of our databases, causing delays in processing traffic.
Posted Oct 25, 2024 - 18:02 EEST
This incident affected: Organic Traffic Analyzer.