Content Writer Incident on recent billing count of articles for trial accounts
Incident Report for SEOmonitor
Resolved
This incident has been resolved.
Posted Oct 17, 2024 - 18:06 EEST
Investigating
We are currently investigating this issue.
Posted Oct 17, 2024 - 17:37 EEST
This incident affected: AI Content Writer.