Incident at one of our third party data providers causing delays in processing

Incident Report for SEOmonitor

Resolved

The incident has been confirmed resolved. No data has been lost, and all systems are back to normal.
Posted Dec 04, 2024 - 13:37 EET

Update

We are continuing to monitor the incident.
The AI Content Writer is also be affected.
Posted Dec 04, 2024 - 09:28 EET

Monitoring

We are monitoring an incident at one of our data providers causing delays in processing new campaigns and new keywords.
Posted Dec 04, 2024 - 08:45 EET
This incident affected: Daily Keyword Tracker, Research Tools, Keyword Import Processor, and AI Content Writer.