Delays in processing new keywords and campaigns

Incident Report for SEOmonitor

Resolved

The incident has been resolved, and all systems are now operating within normal parameters. No data has been lost.
Posted Jun 26, 2025 - 12:00 EEST

Identified

We identified an issue with the processing queues, which was caused by an update on one of the parsers. We are working on implementing a fix.
Posted Jun 25, 2025 - 20:00 EEST

Investigating

We are investigating an issue causing delays in processing new ranks for keywords.
Posted Jun 25, 2025 - 10:46 EEST
This incident affected: Daily Keyword Tracker and Keyword Import Processor.