Crawling Issues

Incident Report for SEOmonitor

Resolved

The incident has been resolved, and all systems are back to normal. No data has been lost.
Posted Jan 20, 2025 - 11:00 EET

Update

The systems are back to normal, but we are continuing to monitor for any potential remaining issues.
Posted Jan 17, 2025 - 20:12 EET

Monitoring

We are still monitoring the incident. Our rank processing systems are still experiencing some degraded performance due to continuous changes in how search results are served.
Posted Jan 17, 2025 - 14:24 EET

Update

We are continuing to investigate this issue.
Posted Jan 17, 2025 - 09:34 EET

Investigating

We are currently investigating this issue.
Posted Jan 17, 2025 - 04:18 EET
This incident affected: Keyword Import Processor and AI Content Writer.