Incident at one of our 3rd party data providers causing delays in processing

Incident Report for SEOmonitor

Resolved

The incident has been confirmed resolved, and all systems are back to normal operating parameters. No data has been lost.
Posted Apr 10, 2025 - 11:11 EEST

Identified

We are experiencing delays in processing new keywords, new campaigns and new articles, caused by a partial outage at one of our 3rd party data providers.
Posted Apr 09, 2025 - 17:50 EEST
This incident affected: Daily Keyword Tracker, Research Tools, Keyword Import Processor, and AI Content Writer.