The incident has been resolved, and all systems are back to normal. No data has been lost.
Posted Apr 18, 2025 - 12:22 EEST
Update
We are continuing to monitor for any further issues or delays, but all systems are reportedly back to normal now.
Posted Apr 17, 2025 - 18:49 EEST
Monitoring
The systems are now mostly operating at their standard capacity. We may still be experiencing some isolated delays, so we continue to monitor the situation.
Posted Apr 17, 2025 - 15:45 EEST
Identified
We have identified an issue with one of our systems related to ranking data, which is causing delays in processing new campaigns, keywords, and articles.
Posted Apr 17, 2025 - 13:53 EEST
This incident affected: Daily Keyword Tracker, Keyword Import Processor, and AI Content Writer.