Incident with our data storage provider, causing slow loading times in the Competition section
Incident Report for SEOmonitor
Resolved
The issue was fixed on our storage provider side, and all systems are back to normal.
Posted Apr 24, 2024 - 17:06 EEST
Identified
Our data storage provider has informed us of an outage on their side, which can cause slow loading times within the Competition section in our Rank Tracker.
Posted Apr 24, 2024 - 14:46 EEST
This incident affected: Webapp.