Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 06, 2024 - 05:30 EET
Scheduled
We will be experiencing issues with our servers, because of the maintenance with our hosting provider. The whole platform can be impacted, and we are expecting intermittent 10-minute downtime intervals within the timeframe.
Posted Dec 05, 2024 - 14:45 EET
This scheduled maintenance affected: Core Platform, Daily Keyword Tracker, Research Tools, Keyword Import Processor, Organic Traffic Analyzer, Content Audit System, AI Content Writer, Reporting Suite, and API Services.