Delays in processing new keywords and campaigns

Incident Report for SEOmonitor

Resolved

The processing is complete.
Posted Apr 09, 2026 - 16:35 EEST

Monitoring

This incident has been fixed. We're currently monitoring the processing to ensure its success.
Posted Apr 09, 2026 - 12:58 EEST

Identified

We identified an issue that is causing delays in processing new keywords and campaigns, and we are working on a fix.
Posted Apr 09, 2026 - 12:32 EEST
This incident affected: Daily Keyword Tracker and AI Content Writer.