Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 07, 2024 - 05:30 EET
Scheduled
We will be experiencing issues with some of our servers, because of the maintenance with our hosting provider. There might be issues with the platform, with API, and data processing.
Posted Nov 05, 2024 - 10:24 EET
This scheduled maintenance affected: Core Platform, Daily Keyword Tracker, Keyword Import Processor, and API Services.