Incident at one of our 3rd party providers causing downtime throughout the platform

Incident Report for SEOmonitor

Monitoring

The systems are now operating within normal functioning parameters, but we are still monitoring for any potential side effects.
Posted Sep 02, 2025 - 00:50 EEST

Investigating

We have identified that one of our servers is affected by an incident at the third-party provider, resulting in downtime throughout the platform. We are working on finding a solution until it's fixed on their side as well.
Posted Sep 02, 2025 - 00:43 EEST
This incident affects: Core Platform.