Delays in processing daily ranks

Incident Report for SEOmonitor

Resolved

This incident has been resolved. No data was lost.
Posted Jan 13, 2026 - 16:30 EET

Identified

We've identified delays in processing daily ranks and implemented a fix.
We expect the data to be populated within the next few hours.
Posted Jan 12, 2026 - 12:25 EET
This incident affected: Daily Keyword Tracker.