Delays in processing new keywords and campaigns

Incident Report for SEOmonitor

Resolved

The incident has been resolved, and all systems are back to normal functioning parameters. No data has been lost.
Posted Sep 04, 2025 - 16:32 EEST

Update

We are continuing to work on a fix, and we're estimating that the systems will be back to normal functioning parameters in 1 hour.
Posted Sep 04, 2025 - 13:44 EEST

Identified

We have identified an issue with the systems, causing slow loading times and delays in processing new keywords and campaigns.
Posted Sep 04, 2025 - 13:35 EEST
This incident affected: Core Platform, Daily Keyword Tracker, and Keyword Import Processor.