Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 14, 2025 - 09:00 EEST
Scheduled
We will be undergoing maintenance on our Competition data servers. There might be intermittent downtime in the Rank Tracker, in the Competition areas, for a few minutes throughout the interval.
Posted May 13, 2025 - 09:00 EEST
This scheduled maintenance affected: Core Platform.