Incident at one of our 3rd party providers causing downtime throughout the platform

Incident Report for SEOmonitor

Resolved

The incident has been resolved. No data has been lost.
Posted Aug 25, 2025 - 12:42 EEST

Monitoring

The systems are now back to normal functioning parameters, but we are still monitoring for any side effects.
Posted Aug 25, 2025 - 00:45 EEST

Identified

We have identified that one of our servers is impacted by an incident at the 3rd-party provider, causing downtime throughout the platform. We are working on finding a solution until it's fixed on their side as well.
Posted Aug 25, 2025 - 00:32 EEST
This incident affected: Core Platform.