Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 21, 2024 - 21:00 EEST
Scheduled
We will be performing maintenance work on some of our our Database Servers.
This might cause data processing delays, intermittent slow loading or downtime periods of up to 15 minutes on some of the campaigns and through the API.
Posted Sep 20, 2024 - 17:07 EEST
This scheduled maintenance affected: Daily Keyword Tracker and Keyword Import Processor.