Incident at our data storage provider causing downtime throughout the platform

Incident Report for SEOmonitor

Resolved

This incident has been resolved. No data was lost.
Posted Jun 29, 2026 - 10:55 EEST

Monitoring

The systems are now back to normal functioning parameters, but we are still monitoring for any side effects.
Posted Jun 27, 2026 - 23:15 EEST

Identified

We have identified an outage at our data storage provider affecting our servers, causing downtime across the platform.
We are working on finding a solution until it's fixed on their side as well.
Posted Jun 27, 2026 - 21:59 EEST
This incident affected: Core Platform.