This incident has been resolved. No data was lost.
Posted Jan 23, 2026 - 19:40 EET
Identified
One of our third-party providers is experiencing an incident that is causing delays in processing new keywords and campaigns on our side. We're monitoring the situation closely to ensure data integrity is not affected.
Posted Jan 23, 2026 - 17:59 EET
This incident affected: Daily Keyword Tracker and AI Content Writer.