Delays in processing data and interface errors when adding keywords or campaigns

Incident Report for SEOmonitor

Resolved

The issue has been confirmed solved. All systems are back to normal. No data has been lost.
Posted Mar 23, 2023 - 16:15 EET

Monitoring

A fix has been implemented and we are monitoring the results, to see what was blocked during the downtime.
Posted Mar 22, 2023 - 14:01 EET

Investigating

We are currently investigating an issue with one of the processing queues, causing delays throughout the platform and possible interface errors.
Posted Mar 22, 2023 - 13:12 EET
This incident affected: Core Platform, Daily Keyword Tracker, and Keyword Import Processor.