Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 17, 2023 - 11:00 EET
Scheduled
We will be undergoing maintenance on one of the Research database servers. Intermittent downtime might be experienced throughout the Research platform, on the US and RO markets; the UK shouldn't be affected.
Posted Mar 16, 2023 - 16:32 EET
This scheduled maintenance affected: Core Platform.