Slow loading throughout the platform
Incident Report for SEOmonitor
Resolved
The incident has been resolved, and all systems are back to normal operating parameters.
Posted Oct 13, 2024 - 13:45 EEST
Investigating
We are investigating an issue with our servers, which causes delays in loading throughout the platform.
Posted Oct 13, 2024 - 01:52 EEST
This incident affected: Core Platform.