Issus with processing AI Search data for new keywords

Incident Report for SEOmonitor

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2026 - 19:57 EET

Identified

We identified an issue that is causing delays in processing AI Search data for new keywords, and we are working on a fix.
Posted Mar 19, 2026 - 12:33 EET
This incident affects: AI Search Tracker.