Delays in writing AIO data

Incident Report for SEOmonitor

Resolved

This incident has been resolved. No data was lost.
Posted Sep 24, 2026 - 12:19 EEST

Identified

We identified an issue causing delays in writing the AIO data. While we're working on the fix, users might experience temporary drops or fluctuations in AIO for the current day.
Posted Sep 24, 2026 - 10:21 EEST
This incident affected: AI Overview.