Slow loading times (or downtime) across the platform
Incident Report for SEOmonitor
Resolved
This incident has been resolved.
Posted Oct 24, 2024 - 07:15 EEST
Identified
We have identified an issue causing slow loading times (or downtime) across the platform, coming from an overload on the database entry point.
Posted Oct 24, 2024 - 07:05 EEST