Delays in processing today's ranks and Visibility
Incident Report for SEOmonitor
Resolved
The issues have been resolved and all systems are back to normal speed. No data has been lost.
Posted May 03, 2021 - 22:00 EEST
Identified
We have identified issues with our ranks and Visibility queues, due to a failure in the storage systems. They are all processing, but at a lower speed.
Posted May 03, 2021 - 08:39 EEST
This incident affected: Rank tracking service and Visibility.