Crawling Issues

Incident Report for SEOmonitor

Resolved

The issue has been identified and fixed.
No data was lost
Posted Jan 16, 2025 - 13:57 EET

Investigating

We are currently investigating this issue.
Posted Jan 16, 2025 - 07:32 EET
This incident affected: Keyword Import Processor.