Platform downtime

Incident Report for SEOmonitor

Resolved

The incident has been solved, and all systems are back to normal. No data has been lost.
Posted Apr 30, 2025 - 12:54 EEST

Investigating

We are investigating an issue causing app.seomonitor.com to be unavailable.
Posted Apr 30, 2025 - 12:45 EEST
This incident affected: Core Platform.